常见软件报错/异常处理方式(二)

一、异常现象:LiteGears出现反复需要验证(验证时提示数据保存成功,但是重新打开软件后依然提示需要验证)

可能的原因有:

  1. 软件的版本问题,升级的原因;
  2. 电脑系统的时间不正确,或者回调过时间;
  3. 系统内装有企业内部用于管理软件行为的软件(安全类,加密类);
  4. 电脑为多用户环境,有其他用户也在使用这个注册码;

解决方法:

  1. 升级到更新的版本,或者覆盖重装一次。
  2. 安装过程中卸载或者关闭杀毒软件。
  3. 寻找企业内部的行为管理软件管理员的帮助
  4. 多用户环境的,须每个用户有独立的注册码

二、软件报错:”Access violation at address 00000000005C8C47 in …..Read of address …..”

原因:
——此问题通常出现在批量工具中,主要原因为添加到批量工具中的某张图纸有异常,图纸数据异常,或者文件损坏。

解决方法:
——报错后批量工具会停止工作,从转换列表中删除出现异常的文件,转换列表中显示为绿色的条目为已完成的。使用SolidWorks打开异常文件,单独执行原批量工作。

三、软件报错:“无法连接到LgService服务,请检查防火墙设置或者 Windows 系统服务!”

原因1
——原电脑安装有2.0之前的旧版LiteGears,升级时未卸载旧版本。

原因1解决方法:
——重新卸载现有安装的软件,同版本或者使用更高版本再安装一次。

原因2
——软件没有安装成功。可以检查系统进程,此情况下没有lgsvr.exe进程。

原因2解决方法:

  1. 卸载LiteGears,然后覆盖安装一次LiteGears,如有360的,重装LiteGears前先卸载360。
  2. 软件不要安装在中文路径下面。
  3. LiteGears软件版本较旧的,下载最新的软件安装包重装。
  4. 电脑中安装有权限管理类软件的,无法私自安装软件的,寻找公司内管理员的帮助。

原因3
——系统防火墙限制

原因3解决方法:
——退出自己安装的防火墙,或者添加信任规则,允许访问网络。检查Windows自带的网络防火墙,如有阻止访问网络的规则,请删除或者添加为允许

四、LiteTools连接SolidWorks后重新打开了一个SolidWorks程序,并提示“…没有打开的文件…”,而不是连接已经打开的SolidWorks程序

原因1:
——安装有多个SolidWorks版本,已打开的SolidWorks与新打开的SolidWorks程序版本不同。

原因1解决方法:
——方案看这里的介绍:https://help.litegears.com/how-about-to-install-more-then-one-version-of-solidworks.html

原因2:
——SolidWorks以管理员运行了,但LiteTools以普通权限运行,或者两者反过来,总之两者的运行权限不相等。

原因2解决方法:

  1. 将SolidWorks与LiteTools的运行权限设置为相同,都是普通权限或者都是管理员权限。
  2. 从SolidWorks的工具栏进入LiteTools。